Blorp (scsi) wrote in lj_everywhere,
Blorp
scsi
lj_everywhere

Has anyone gotten ssl via mod-perl-ssl.pl to work?

I'm having one hell of a time.. The daemon doesnt start, but gcache does.
This is a vanilla debian machine with apache, apache-perl, and apache-ssl installed.

Something else thats wierd:
trinary:~# apache-sslctl configtest
Syntax OK
/usr/sbin/apache-sslctl: line 171: 30828 Segmentation fault $HTTPD -t




ServerType standalone
ServerRoot /etc/apache-ssl/
PidFile /var/run/apache-ssl.pid
ScoreBoardFile /var/run/apache-ssl.scoreboard
Timeout 30

KeepAlive Off
MaxKeepAliveRequests 200
KeepAliveTimeout 50

MinSpareServers 5
MaxSpareServers 15
StartServers 10
MaxClients 20
MaxRequestsPerChild 256

LoadModule config_log_module /usr/lib/apache/1.3/mod_log_config_ssl.so
LoadModule dir_module /usr/lib/apache/1.3/mod_dir.so
LoadModule mime_module /usr/lib/apache/1.3/mod_mime_ssl.so
LoadModule perl_module /usr/lib/apache/1.3/mod_perl.so
LoadModule apache_ssl_module /usr/lib/apache/1.3/libssl.so


BindAddress 209.142.3.149
Port 443

User www-data
Group www-data

SendBufferSize 131072

SSLEnable
SSLCacheServerPath /usr/lib/apache-ssl/gcache
SSLCacheServerPort /var/run/gcache_port
SSLSessionCacheTimeout 15
SSLCACertificatePath /etc/apache-ssl
SSLCertificateFile /etc/apache-ssl/apache.pem
SSLVerifyClient 0
SSLVerifyDepth 10

ServerName trinary.deadjournal.org
PerlSetEnv LJHOME /home/lj
PerlRequire /home/lj/cgi-bin/modperl-ssl.pl
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
CustomLog /var/log/apache-ssl/access.log combined
ErrorLog /var/log/apache-ssl/error.log
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 2 comments