centyx (centyx) wrote in lj_everywhere,
centyx
centyx
lj_everywhere

dynaloader version mismatch?

Hi. Using debian unstable w/ debian packages for apache 1.3.29, mod-perl, and all required perl modules. perl is debian's 5.8.4.

I am at the beginning of setting up livejournal.
After running bootstrap and adding the lines
PerlSetEnv LJHOME /u1/sites/lj
PerlRequire /u1/sites/lj/cgi-bin/modperl.pl
to http.conf, restarting apache spews out the following errors:
[Tue May 25 17:07:48 2004] [error] DynaLoader object version 1.05 does not match $DynaLoader::VERSION 1.04 at /usr/lib/perl/5.8/XSLoader.pm line 16.
Compilation failed in require at /usr/lib/perl/5.8/Fcntl.pm line 6.
BEGIN failed--compilation aborted at /usr/lib/perl/5.8/Fcntl.pm line 6.
Compilation failed in require at /usr/lib/perl5/Apache/File.pm line 4.
BEGIN failed--compilation aborted at /usr/lib/perl5/Apache/File.pm line 4.
Compilation failed in require at /u1/sites/lj/cgi-bin/Apache/LiveJournal.pm line 8.
BEGIN failed--compilation aborted at /u1/sites/lj/cgi-bin/Apache/LiveJournal.pm line 8.
Compilation failed in require at /u1/sites/lj/cgi-bin/modperl_subs.pl line 11.
BEGIN failed--compilation aborted at /u1/sites/lj/cgi-bin/modperl_subs.pl line 11.
Compilation failed in require at /u1/sites/lj/cgi-bin/modperl.pl line 10.
Compilation failed in require at (eval 2) line 1.

Syntax error on line 300 of /etc/apache/httpd.conf:
DynaLoader object version 1.05 does not match $DynaLoader::VERSION 1.04 at /usr/lib/perl/5.8/XSLoader.pm line 16.
Compilation failed in require at /usr/lib/perl/5.8/Fcntl.pm line 6.
BEGIN failed--compilation aborted at /usr/lib/perl/5.8/Fcntl.pm line 6.
Compilation failed in require at /usr/lib/perl5/Apache/File.pm line 4.
BEGIN failed--compilation aborted at /usr/lib/perl5/Apache/File.pm line 4.
Compilation failed in require at /u1/sites/lj/cgi-bin/Apache/LiveJournal.pm line 8.
BEGIN failed--compilation aborted at /u1/sites/lj/cgi-bin/Apache/LiveJournal.pm line 8.
Compilation failed in require at /u1/sites/lj/cgi-bin/modperl_subs.pl line 11.
BEGIN failed--compilation aborted at /u1/sites/lj/cgi-bin/modperl_subs.pl line 11.
Compilation failed in require at /u1/sites/lj/cgi-bin/modperl.pl line 10.
Compilation failed in require at (eval 2) line 1.

Any suggestions would be greatly appreciated.
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 2 comments