exquiror (exquiror) wrote in lj_everywhere,
exquiror
exquiror
lj_everywhere

Error starting up server after fresh install

Hi,
I just set up an LJ server, following instructions mostly from http://wiki.huihoo.com/index.php?title=LiveJournal_Server (as wiki.ljcode.org is spitting out a mysql error right now). Everything seemed to work but I can't start the server up. The problem seems to be in cgi-bin/modperl.pl when it gets loaded by the PerlRequire line in httpd.conf. When I start up apache-perl I get the following:

Configuration syntax error detected. Not reloading.

Use of uninitialized value in concatenation (.) or string at /var/www/lj/cgi-bin/weblib.pl line 3094.
[Sat Mar 17 12:32:00 2007] [error] Can't locate /var/www/lj/cgi-bin/console.pl in @INC (@INC contains: /var/www/lj/cgi-bin /var/www/lj/src/s2 CODE(0x81568e4) /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 . /usr/ /usr/lib/perl) at /var/www/lj/cgi-bin/ljprotocol.pl line 17.\nCompilation failed in require at /var/www/lj/cgi-bin/Apache/LiveJournal.pm line 43.\nBEGIN failed--compilation aborted at /var/www/lj/cgi-bin/Apache/LiveJournal.pm line 47.\nCompilation failed in require at /var/www/lj/cgi-bin/modperl_subs.pl line 11.\nBEGIN failed--compilation aborted at /var/www/lj/cgi-bin/modperl_subs.pl line 11.\nCompilation failed in require at /var/www/lj/cgi-bin/modperl.pl line 20.\nCompilation failed in require at (eval 2) line 1.\n
Syntax error on line 3 of /etc/apache-perl/httpd.conf:
Can't locate /var/www/lj/cgi-bin/console.pl in @INC (@INC contains: /var/www/lj/cgi-bin /var/www/lj/src/s2 CODE(0x81568e4) /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 . /usr/ /usr/lib/perl) at /var/www/lj/cgi-bin/ljprotocol.pl line 17.
Compilation failed in require at /var/www/lj/cgi-bin/Apache/LiveJournal.pm line 43.
BEGIN failed--compilation aborted at /var/www/lj/cgi-bin/Apache/LiveJournal.pm line 47.
Compilation failed in require at /var/www/lj/cgi-bin/modperl_subs.pl line 11.
BEGIN failed--compilation aborted at /var/www/lj/cgi-bin/modperl_subs.pl line 11.
Compilation failed in require at /var/www/lj/cgi-bin/modperl.pl line 20.
Compilation failed in require at (eval 2) line 1.



I have updated from the svn/cvs repos but there is no console.pl anywhere in there.

I also get some config errors when I run checkconfig.pl, however, these refer to config options that don't even exist, so I figured thats prob just some deprecated code in there, all other tests pass. Just in case heres the output from it:

Problem:
* Config errors: Unknown config option: $ALLOW_CLUSTER_SELECT,
Unknown config option: $DIR_DB,
Unknown config option: $DIR_DB_HOST,
Unknown config option: $MAX_32BIT_SIGNED,
Unknown config option: $MAX_32BIT_UNSIGNED,
Unknown config option: $MAX_HINTS_LASTN,
Unknown config option: $SMS_DOMAIN,
Unknown config option: $SMS_TITLE,
Unknown config option: $SYN_LASTN_S1,
Unknown config option: $TEMP,
Unknown config option: $VAR,
Unknown config option: $_LJLIB_INIT,
Unknown config option: @EVENT_TYPES,
Unknown config option: @NOTIFY_TYPES


I have all the relevant perl modules installed and all that stuff. Can anyone help me get to the bottom of this?
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 5 comments