September 7th, 2003

(no subject)

I gave up on running the LiveJournal code on my site for awhile, but I'm trying to give it a shot...I downloaded from CVS, and I can't populate the mysql database...

Here's the error when I start up apache without the database populated...

speed-lj# /usr/local/apache/bin/apachectl start
Use of uninitialized value in concatenation (.) or string at /web/devcore.us/cgi-bin/ljdefaults.pl line 43.
Use of uninitialized value in concatenation (.) or string at /web/devcore.us/cgi-bin/ljdefaults.pl line 56.
/usr/local/apache/bin/apachectl start: httpd started


And here is the error when I try to update the database...

$ bin/upgrading/update-db.pl --runsql --populate
Use of uninitialized value in concatenation (.) or string at /web/devcore.us/cgi-bin/DBI/Role.pm line 241.
Use of uninitialized value in concatenation (.) or string at /web/devcore.us/cgi-bin/DBI/Role.pm line 241.
Can't connect to the database (clust#0), so I can't update it.

I threw in 'dbname' => 'livejournal', in the ljconfig.pl file just to see if it would help, since I know the lj user can access it with the password I have typed in the config file, and I've restarted the mysql server, but nothing helps. What am I missing here?

Auto Community Joining

Hello, I am attempting to deploy a LiveJournal installation in my local school district, and am attempting to make some very specific changes to code. I have made many successfully, but I would like to do the following things, if anyone knows how, it would be greatly appreciated if they would share their knowledge with me:

1) A link in bluewhite.look that allows the user to view their journal if they are logged in, and prompts them to login if they are not already.

2) A Requirement to login before you can even see the homepage or any subsequent pages.

3) Whenever a new user is created, the user is automatically made a member of communities called "homework," "revisions," "science," "sports," and "other."

4) The creation of a custom public color theme.

5) Removal of the "Date" and "Local time" fields from the update.bml page, while STILL broadcasting the Date and Local time (else it doesn't work).

6) Insertion of [lj-user="asdf"] and [lj-comm="asdf"] (yes, those are supposed to be "<" and ">") into the en.dat file.


Thanks in advance if you can help on ANY of these issues!