The Fenux (fenux) wrote in lj_everywhere,
The Fenux
fenux
lj_everywhere

Installation Problems

I'm installing the latest LiveJournal code from CVS (as of late last night) onto a FreeBSD 5.5-PRERELEASE box. It's running Apache 1.3.34 with mod_perl 1.29 and MySQL 5.0.15. After some inital troubles because I misconfigured ljconfig.pl, I started the whole process from scratch and the install went fine from there.

I added the PerlSetEnv and PerlRequire lines to my directive, the other settings listed in the installation help were already there. Now if I restart apache with those lines, it will seg fault on me.

I'm in the process of upgrading my whole perl system from the FreeBSD ports collection. A couple of my perl modules were out of date.

While I'm waiting, I thought I'd ask if anyone has an idea of why it might be doing this. Any ideas?

Update: Found the problem... Sort of. It seems to have been a problem with my apache installation. I installed a seperate installation of apache 1.3 on the box with only mod_perl and it seems to work now.

Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 3 comments